Installation

The preferred way to install Swiftmailer is via Composer:

$ php composer.phar require swiftmailer/swiftmailer @stable

Looking for downloadable releases?

This page explains how to use Swiftmailer as a Composer packages. If you need to get hold of an older version of SwiftMailer as an archive, check our archive, which holds downloads right back to version 1.

Source Code Repository Access

If you want to keep up-to-date with the very latest developments as they happen you can install and use Swift Mailer directly from our source code repository, which currently uses Git and is hosted over at GitHub.

PEAR Channel

The Swiftmailer PEAR channel is deprecated now. Use Composer instead.